const regex = /(?<=@)\S+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=@)\\S+', 'g')
const str = `abasc@firstreoblcicmc.do.com`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);