import Foundation
let pattern = #"(?<=@)\S+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"abasc@firstreoblcicmc.do.com"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)