$re = '/(?<=@)\S+/';
$str = 'abasc@firstreoblcicmc.do.com';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;