use strict;
my $str = 'abasc@firstreoblcicmc.do.com';
my $regex = qr/(?<=@)\S+/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";