# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/https?:\S+|www\.\S+//gm;t' <<< "This film was a complete disappointment. Waste of time! Visit http://worstfilms.com for more terrible movies."