// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)https?:\S+|www\.\S+").unwrap();
let string = "This film was a complete disappointment. Waste of time! Visit http://worstfilms.com for more terrible movies.";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}