#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)https?:\S+|www\.\S+"
Local $sString = "This film was a complete disappointment. Waste of time! Visit http://worstfilms.com for more terrible movies."
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)