re = /https?:\S+|www\.\S+/m
str = 'This film was a complete disappointment. Waste of time! Visit http://worstfilms.com for more terrible movies.'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result