$re = '/https?:\S+|www\.\S+/m';
$str = 'This film was a complete disappointment. Waste of time! Visit http://worstfilms.com for more terrible movies.';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;