# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\d)[.,;:](?!\d)//g;t' <<< "This is a 1example of the text. But, it only is 2.5 percent of all data\""