$re = '/(?<!\d)[.,;:](?!\d)/';
$str = 'This is a 1example of the text. But, it only is 2.5 percent of all data"';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;