import Foundation
let pattern = #"(?<!\d)[.,;:](?!\d)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"This is a 1example of the text. But, it only is 2.5 percent of all data""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)