const regex = new RegExp('(?<!\\d)[.,;:](?!\\d)', 'g')
const str = `This is a 1example of the text. But, it only is 2.5 percent of all data"`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);