use strict;
my $str = 'This is a 1example of the text. But, it only is 2.5 percent of all data"';
my $regex = qr/(?<!\d)[.,;:](?!\d)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";