using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!My )\bItem 1\b(?! Test)";
string substitution = @"Something";
string input = @"Remove this Item 1, but not My Item 1, Item 1 Test, nor Item 11, Item 12 just for fun
Only Item 11 left due to the promotion on Item 1";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}