$re = '/(?<!My )\bItem 1\b(?! Test)/m';
$str = 'Remove this Item 1, but not My Item 1, Item 1 Test, nor Item 11, Item 12 just for fun
Only Item 11 left due to the promotion on Item 1';
$subst = "Something";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;