const regex = /(?<!My )\bItem 1\b(?! Test)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!My )\\bItem 1\\b(?! Test)', 'gm')
const str = `Remove this Item 1, but not My Item 1, Item 1 Test, nor Item 11, Item 12 just for fun
Only Item 11 left due to the promotion on Item 1`;
const subst = `Something`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);