# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!My )\bItem 1\b(?! Test)"
test_str = ("Remove this Item 1, but not My Item 1, Item 1 Test, nor Item 11, Item 12 just for fun\n\n"
"Only Item 11 left due to the promotion on Item 1")
subst = "Something"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.