import Foundation
let pattern = #"(?<!My )\bItem 1\b(?! Test)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Remove this Item 1, but not My Item 1, Item 1 Test, nor Item 11, Item 12 just for fun
Only Item 11 left due to the promotion on Item 1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"Something"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)