const regex = /.*webnovel\.com\/(vote|book\/[0-9]+\/[^0-9]*|rssbook\/.*|)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*webnovel\\.com\\\/(vote|book\\\/[0-9]+\\\/[^0-9]*|rssbook\\\/.*|)', 'g')
const str = `.*webnovel\\.com\\/(vote|book\\/\\d+\\/\\D*|rssbook\\/.*|)
https://www.webnovel.com/book/6838665602002705/23700208386889837/The-Avalon-Of-Five-Elements/Break-Even
https://www.webnovel.com/book/8102217006003305/22972070770045319/Ultimate-Scheming-System/Buddha%E2%80%99s-Fiery-Lotus,-Explode!
https://www.webnovel.com/rssbook/8102217006003305/22972070770045319
https://www.webnovel.com/
https://www.webnovel.com/book/6838665602002705/The-Avalon-Of-Five-Elements
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}