#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([^\|\s]\s*\[x\]\s*\K[^!|\n]*|(?:\G(?!\A)\||(?<=\[x]\s)\s*\|)\K[^|\n]*(?=\|))|([^\|\s]\s*\[x\]\s*\!\s*\K[^|\n]*|(?:\G(?!\A)\||(?<=\[x]\s)\s*\!\s*\|)\K[^|\n]*(?=\|))"
Local $sString = "Text for testing:" & @CRLF & _
"- [x] Example task. | Task ends. [x] Another task." & @CRLF & _
"- [x] ! Example task. | This ends. [x] ! Another task." & @CRLF & _
"" & @CRLF & _
"This is a sentence. [x] Task is here." & @CRLF & _
"Other text. Another [x] ! Task is here." & @CRLF & _
"" & @CRLF & _
"| | Task name | Plan | Actual | File |" & @CRLF & _
"| :---- | :-------------| :---------: | :---------: | :------------: |" & @CRLF & _
"| [x] | Task example. | 08:00-08:45 | 08:00-09:00 | [[task-one]] |" & @CRLF & _
"| [x] ! | Task example. | 08:00-08:45 | 08:00-09:00 | [[task-one]] |" & @CRLF & _
"" & @CRLF & _
"Description:" & @CRLF & _
"- $1:" & @CRLF & _
" - outside the table: capture everything after `[x]` (i.e., not followed by `!`) until a `|`" & @CRLF & _
" - inside the table: capture everything after `[x]` (i.e., not followed by `!`) excluding the `|` symbols" & @CRLF & _
"- $2:" & @CRLF & _
" - outside the table: capture everything after `[x] !` until a `|`" & @CRLF & _
" - inside the table: capture everything after `[x] !` excluding the `|` symbols" & @CRLF & _
"" & @CRLF & _
"Expressions for each group:" & @CRLF & _
"- $1:" & @CRLF & _
" - outside the table: [^\|\s]\s*\[x\]\s*\K[^!|\n]*" & @CRLF & _
" - inside the table: (?:\G(?!\A)\||(?<=\[x]\s)\s*\|)\K[^|\n]*(?=\|)" & @CRLF & _
"- $2:" & @CRLF & _
" - outside the table: [^\|\s]\s*\[x\]\s*\!\s*\K[^|\n]*" & @CRLF & _
" - inside the table: (?:\G(?!\A)\||(?<=\[x]\s)\s*\!\s*\|)\K[^|\n]*(?=\|)" & @CRLF & _
"" & @CRLF & _
"Combined expression:" & @CRLF & _
"([^\|\s]\s*\[x\]\s*\K[^!|\n]*|(?:\G(?!\A)\||(?<=\[x]\s)\s*\|)\K[^|\n]*(?=\|))|([^\|\s]\s*\[x\]\s*\!\s*\K[^|\n]*|(?:\G(?!\A)\||(?<=\[x]\s)\s*\!\s*\|)\K[^|\n]*(?=\|))" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")