use strict;
my $str = 'Text for testing:
- [x] Example task. | Task ends. [x] Another task.
- [x] ! Example task. | This ends. [x] ! Another task.
This is a sentence. [x] Task is here.
Other text. Another [x] ! Task is here.
| | Task name | Plan | Actual | File |
| :---- | :-------------| :---------: | :---------: | :------------: |
| [x] | Task example. | 08:00-08:45 | 08:00-09:00 | [[task-one]] |
| [x] ! | Task example. | 08:00-08:45 | 08:00-09:00 | [[task-one]] |
Description:
- $1:
- outside the table: capture everything after `[x]` (i.e., not followed by `!`) until a `|`
- inside the table: capture everything after `[x]` (i.e., not followed by `!`) excluding the `|` symbols
- $2:
- outside the table: capture everything after `[x] !` until a `|`
- inside the table: capture everything after `[x] !` excluding the `|` symbols
Expressions for each group:
- $1:
- outside the table: [^\\|\\s]\\s*\\[x\\]\\s*\\K[^!|\\n]*
- inside the table: (?:\\G(?!\\A)\\||(?<=\\[x]\\s)\\s*\\|)\\K[^|\\n]*(?=\\|)
- $2:
- outside the table: [^\\|\\s]\\s*\\[x\\]\\s*\\!\\s*\\K[^|\\n]*
- inside the table: (?:\\G(?!\\A)\\||(?<=\\[x]\\s)\\s*\\!\\s*\\|)\\K[^|\\n]*(?=\\|)
Combined expression:
([^\\|\\s]\\s*\\[x\\]\\s*\\K[^!|\\n]*|(?:\\G(?!\\A)\\||(?<=\\[x]\\s)\\s*\\|)\\K[^|\\n]*(?=\\|))|([^\\|\\s]\\s*\\[x\\]\\s*\\!\\s*\\K[^|\\n]*|(?:\\G(?!\\A)\\||(?<=\\[x]\\s)\\s*\\!\\s*\\|)\\K[^|\\n]*(?=\\|))
';
my $regex = qr/([^\|\s]\s*\[x\]\s*\K[^!|\n]*|(?:\G(?!\A)\||(?<=\[x]\s)\s*\|)\K[^|\n]*(?=\|))|([^\|\s]\s*\[x\]\s*\!\s*\K[^|\n]*|(?:\G(?!\A)\||(?<=\[x]\s)\s*\!\s*\|)\K[^|\n]*(?=\|))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}