import re
regex = re.compile(r"([^\|\s]\s*\[x\]\s*\K[^!|\n]*|(?:\G(?!\A)\||(?<=\[x]\s)\s*\|)\K[^|\n]*(?=\|))|([^\|\s]\s*\[x\]\s*\!\s*\K[^|\n]*|(?:\G(?!\A)\||(?<=\[x]\s)\s*\!\s*\|)\K[^|\n]*(?=\|))", flags=re.MULTILINE)
test_str = ("Text for testing:\n"
"- [x] Example task. | Task ends. [x] Another task.\n"
"- [x] ! Example task. | This ends. [x] ! Another task.\n\n"
"This is a sentence. [x] Task is here.\n"
"Other text. Another [x] ! Task is here.\n\n"
"| | Task name | Plan | Actual | File |\n"
"| :---- | :-------------| :---------: | :---------: | :------------: |\n"
"| [x] | Task example. | 08:00-08:45 | 08:00-09:00 | [[task-one]] |\n"
"| [x] ! | Task example. | 08:00-08:45 | 08:00-09:00 | [[task-one]] |\n\n"
"Description:\n"
"- $1:\n"
" - outside the table: capture everything after `[x]` (i.e., not followed by `!`) until a `|`\n"
" - inside the table: capture everything after `[x]` (i.e., not followed by `!`) excluding the `|` symbols\n"
"- $2:\n"
" - outside the table: capture everything after `[x] !` until a `|`\n"
" - inside the table: capture everything after `[x] !` excluding the `|` symbols\n\n"
"Expressions for each group:\n"
"- $1:\n"
" - outside the table: [^\\|\\s]\\s*\\[x\\]\\s*\\K[^!|\\n]*\n"
" - inside the table: (?:\\G(?!\\A)\\||(?<=\\[x]\\s)\\s*\\|)\\K[^|\\n]*(?=\\|)\n"
"- $2:\n"
" - outside the table: [^\\|\\s]\\s*\\[x\\]\\s*\\!\\s*\\K[^|\\n]*\n"
" - inside the table: (?:\\G(?!\\A)\\||(?<=\\[x]\\s)\\s*\\!\\s*\\|)\\K[^|\\n]*(?=\\|)\n\n"
"Combined expression:\n"
"([^\\|\\s]\\s*\\[x\\]\\s*\\K[^!|\\n]*|(?:\\G(?!\\A)\\||(?<=\\[x]\\s)\\s*\\|)\\K[^|\\n]*(?=\\|))|([^\\|\\s]\\s*\\[x\\]\\s*\\!\\s*\\K[^|\\n]*|(?:\\G(?!\\A)\\||(?<=\\[x]\\s)\\s*\\!\\s*\\|)\\K[^|\\n]*(?=\\|))\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")