$re = '/([^\|\s]\s*\[x\]\s*\K[^!|\n]*|(?:\G(?!\A)\||(?<=\[x]\s)\s*\|)\K[^|\n]*(?=\|))|([^\|\s]\s*\[x\]\s*\!\s*\K[^|\n]*|(?:\G(?!\A)\||(?<=\[x]\s)\s*\!\s*\|)\K[^|\n]*(?=\|))/m';
$str = 'Text for testing:
- [x] Example task. | Task ends. [x] Another task.
- [x] ! Example task. | This ends. [x] ! Another task.
This is a sentence. [x] Task is here.
Other text. Another [x] ! Task is here.
| | Task name | Plan | Actual | File |
| :---- | :-------------| :---------: | :---------: | :------------: |
| [x] | Task example. | 08:00-08:45 | 08:00-09:00 | [[task-one]] |
| [x] ! | Task example. | 08:00-08:45 | 08:00-09:00 | [[task-one]] |
Description:
- $1:
- outside the table: capture everything after `[x]` (i.e., not followed by `!`) until a `|`
- inside the table: capture everything after `[x]` (i.e., not followed by `!`) excluding the `|` symbols
- $2:
- outside the table: capture everything after `[x] !` until a `|`
- inside the table: capture everything after `[x] !` excluding the `|` symbols
Expressions for each group:
- $1:
- outside the table: [^\\|\\s]\\s*\\[x\\]\\s*\\K[^!|\\n]*
- inside the table: (?:\\G(?!\\A)\\||(?<=\\[x]\\s)\\s*\\|)\\K[^|\\n]*(?=\\|)
- $2:
- outside the table: [^\\|\\s]\\s*\\[x\\]\\s*\\!\\s*\\K[^|\\n]*
- inside the table: (?:\\G(?!\\A)\\||(?<=\\[x]\\s)\\s*\\!\\s*\\|)\\K[^|\\n]*(?=\\|)
Combined expression:
([^\\|\\s]\\s*\\[x\\]\\s*\\K[^!|\\n]*|(?:\\G(?!\\A)\\||(?<=\\[x]\\s)\\s*\\|)\\K[^|\\n]*(?=\\|))|([^\\|\\s]\\s*\\[x\\]\\s*\\!\\s*\\K[^|\\n]*|(?:\\G(?!\\A)\\||(?<=\\[x]\\s)\\s*\\!\\s*\\|)\\K[^|\\n]*(?=\\|))
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);