const regex = /([^\|\s]\s*\[x\]\s*\K[^!|\n]*|(?:\G(?!\A)\||(?<=\[x]\s)\s*\|)\K[^|\n]*(?=\|))|([^\|\s]\s*\[x\]\s*\!\s*\K[^|\n]*|(?:\G(?!\A)\||(?<=\[x]\s)\s*\!\s*\|)\K[^|\n]*(?=\|))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^\\|\\s]\\s*\\[x\\]\\s*\\K[^!|\\n]*|(?:\\G(?!\\A)\\||(?<=\\[x]\\s)\\s*\\|)\\K[^|\\n]*(?=\\|))|([^\\|\\s]\\s*\\[x\\]\\s*\\!\\s*\\K[^|\\n]*|(?:\\G(?!\\A)\\||(?<=\\[x]\\s)\\s*\\!\\s*\\|)\\K[^|\\n]*(?=\\|))', 'gm')
const str = `Text for testing:
- [x] Example task. | Task ends. [x] Another task.
- [x] ! Example task. | This ends. [x] ! Another task.
This is a sentence. [x] Task is here.
Other text. Another [x] ! Task is here.
| | Task name | Plan | Actual | File |
| :---- | :-------------| :---------: | :---------: | :------------: |
| [x] | Task example. | 08:00-08:45 | 08:00-09:00 | [[task-one]] |
| [x] ! | Task example. | 08:00-08:45 | 08:00-09:00 | [[task-one]] |
Description:
- \$1:
- outside the table: capture everything after \`[x]\` (i.e., not followed by \`!\`) until a \`|\`
- inside the table: capture everything after \`[x]\` (i.e., not followed by \`!\`) excluding the \`|\` symbols
- \$2:
- outside the table: capture everything after \`[x] !\` until a \`|\`
- inside the table: capture everything after \`[x] !\` excluding the \`|\` symbols
Expressions for each group:
- \$1:
- outside the table: [^\\|\\s]\\s*\\[x\\]\\s*\\K[^!|\\n]*
- inside the table: (?:\\G(?!\\A)\\||(?<=\\[x]\\s)\\s*\\|)\\K[^|\\n]*(?=\\|)
- \$2:
- outside the table: [^\\|\\s]\\s*\\[x\\]\\s*\\!\\s*\\K[^|\\n]*
- inside the table: (?:\\G(?!\\A)\\||(?<=\\[x]\\s)\\s*\\!\\s*\\|)\\K[^|\\n]*(?=\\|)
Combined expression:
([^\\|\\s]\\s*\\[x\\]\\s*\\K[^!|\\n]*|(?:\\G(?!\\A)\\||(?<=\\[x]\\s)\\s*\\|)\\K[^|\\n]*(?=\\|))|([^\\|\\s]\\s*\\[x\\]\\s*\\!\\s*\\K[^|\\n]*|(?:\\G(?!\\A)\\||(?<=\\[x]\\s)\\s*\\!\\s*\\|)\\K[^|\\n]*(?=\\|))
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}