package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(^|\r?\n)[^\d\n]+\r?\n(\r?\n|$)`)
var str = `hello
1
world
2`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}