const regex = /(^|\r?\n)[^\d\n]+\r?\n(\r?\n|$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|\\r?\\n)[^\\d\\n]+\\r?\\n(\\r?\\n|$)', 'g')
const str = `hello
1
world
2`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);