re = /(^|\r?\n)[^\d\n]+\r?\n(\r?\n|$)/
str = 'hello
1
world
2'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result