use strict;
my $str = 'hello
1
world
2';
my $regex = qr/(^|\r?\n)[^\d\n]+\r?\n(\r?\n|$)/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";