$re = '/(^|\r?\n)[^\d\n]+\r?\n(\r?\n|$)/';
$str = 'hello
1
world
2';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;