import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "additem/([0-9]+(?:\\.[0-9]{1,2})?)$";
final String string = "additem/24\n"
+ "additem/24.5\n"
+ "additem/24.55";
final String subst = "additem.php?price=$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}