$re = '~additem/([0-9]+(?:\.[0-9]{1,2})?)$~m';
$str = 'additem/24
additem/24.5
additem/24.55';
$subst = "additem.php?price=$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;