// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)additem/([0-9]+(?:\.[0-9]{1,2})?)$").unwrap();
let string = "additem/24
additem/24.5
additem/24.55";
let substitution = "additem.php?price=$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}