use strict;
my $str = 'additem/24
additem/24.5
additem/24.55';
my $regex = qr~additem/([0-9]+(?:\.[0-9]{1,2})?)$~mp;
my $subst = 'additem.php?price=$1';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";