const regex = new RegExp('additem/([0-9]+(?:\\.[0-9]{1,2})?)$', 'gm')
const str = `additem/24
additem/24.5
additem/24.55`;
const subst = `additem.php?price=$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);