import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<! (a|an|the|that|this|those|my|your|his|her|our|their|its|one's|up) ([a-z]+ing)";
final String string = "<p class=\"calibre1\">“This is the first sentence.</p>\n"
+ "<p class=\"calibre1\">And this is the second!â€</p>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}