re = /(?<! (a|an|the|that|this|those|my|your|his|her|our|their|its|one's|up) ([a-z]+ing)/
str = '<p class="calibre1">“This is the first sentence.</p>
<p class="calibre1">And this is the second!â€</p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end