import Foundation
let pattern = #"(?<! (a|an|the|that|this|those|my|your|his|her|our|their|its|one's|up) ([a-z]+ing)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<p class="calibre1">“This is the first sentence.</p>
<p class="calibre1">And this is the second!â€</p>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)