use strict;
my $str = '<p class="calibre1">“This is the first sentence.</p>
<p class="calibre1">And this is the second!â€</p>';
my $regex = qr/(?<! (a|an|the|that|this|those|my|your|his|her|our|their|its|one's|up) ([a-z]+ing)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}