# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:Mo|Tu|We|Th|Fr|Sa|Su)+\s*[\d]{2}:[\d]{2}A?P?M\s*-\s*[\d]{2}:[\d]{2}A?P?M//gm;t' <<< "MoWe 04:30PM - 05:50PM
Fr 12:00PM - 01:20PM
fooo
"