package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:Mo|Tu|We|Th|Fr|Sa|Su)+\s*[\d]{2}:[\d]{2}A?P?M\s*-\s*[\d]{2}:[\d]{2}A?P?M`)
var str = `MoWe 04:30PM - 05:50PM
Fr 12:00PM - 01:20PM
fooo
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}