const regex = new RegExp('(?:Mo|Tu|We|Th|Fr|Sa|Su)+\\s*[\\d]{2}:[\\d]{2}A?P?M\\s*-\\s*[\\d]{2}:[\\d]{2}A?P?M', 'gm')
const str = `MoWe 04:30PM - 05:50PM
Fr 12:00PM - 01:20PM
fooo
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);