import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:Mo|Tu|We|Th|Fr|Sa|Su)+\\s*[\\d]{2}:[\\d]{2}A?P?M\\s*-\\s*[\\d]{2}:[\\d]{2}A?P?M";
final String string = "MoWe 04:30PM - 05:50PM\n"
+ "Fr 12:00PM - 01:20PM\n"
+ "fooo\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}