# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:Mo|Tu|We|Th|Fr|Sa|Su)+\s*[\d]{2}:[\d]{2}A?P?M\s*-\s*[\d]{2}:[\d]{2}A?P?M"
test_str = ("MoWe 04:30PM - 05:50PM\n"
"Fr 12:00PM - 01:20PM\n"
"fooo\n")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.