using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\((.+)\)$";
string input = @"Happy Day Care Club (1124734)
French Pattiserie (8985D)
The King's Pantry (G6666642742D)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}