package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\((.+)\)$`)
var str = `Happy Day Care Club (1124734)
French Pattiserie (8985D)
The King's Pantry (G6666642742D)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}