re = /\((.+)\)$/m
str = 'Happy Day Care Club (1124734)
French Pattiserie (8985D)
The King\'s Pantry (G6666642742D)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end