$re = '/\((.+)\)$/m';
$str = 'Happy Day Care Club (1124734)
French Pattiserie (8985D)
The King\'s Pantry (G6666642742D)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);