#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(\bByVal\b|\bByRef\b)? +(\w+)(?: +as +(\w+))?(?: *= *[\w"]+)? *[\)|,]?"
Local $sString = " ByVal S_Random, ByVal S_Sign_JS, ByRef S_Ksc, ByRef HS_EkscEkakscn, ByRef intResult, ByVal strEKA, ByVal strNmLogon, ByVal StrNivelUsuario, ByVal lngIDConexao, ByVal strBanco, ByVal strAgencia, ByVal strConta, ByVal strTipoDePessoa, ByVal lngCodUsuario, ByVal lngContrato, ByRef LngRetCode, ByRef strErro, ByRef strErroTecnica, ByVal intIdCanal, ByVal strIPAddrCliente, ByVal strIPAddrServer, Optional ByRef S_PW, Optional ByRef S_PBE"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")