// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)(\bByVal\b|\bByRef\b)? +(\w+)(?: +as +(\w+))?(?: *= *[\w"]+)? *[\)|,]?"#).unwrap();
let string = " ByVal S_Random, ByVal S_Sign_JS, ByRef S_Ksc, ByRef HS_EkscEkakscn, ByRef intResult, ByVal strEKA, ByVal strNmLogon, ByVal StrNivelUsuario, ByVal lngIDConexao, ByVal strBanco, ByVal strAgencia, ByVal strConta, ByVal strTipoDePessoa, ByVal lngCodUsuario, ByVal lngContrato, ByRef LngRetCode, ByRef strErro, ByRef strErroTecnica, ByVal intIdCanal, ByVal strIPAddrCliente, ByVal strIPAddrServer, Optional ByRef S_PW, Optional ByRef S_PBE";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}